SharePoint
Feedback by UserVoice

How can we improve Microsoft SharePoint Apps for iOS?

Onprem does not work

I connected to our onpremise sharepoint via vpn. Basically nothing happens. None of the functions are working.

151 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Alperen Paker shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    32 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  ·   ·  Flag as inappropriate

        we're seeing: alamofire.AFError error3
        when people aren't an owner of the site. when they are an owner the message doesn't appear.

      • Andrew Federico commented  ·   ·  Flag as inappropriate

        The app's on-prem functionality is completely busted, and dangerous.

        I have several web apps, with one an Extranet. When you attempt to access the Extranet which is SSL, it does not show the content and says there was an error, but prompts to enter the server address, and automatically populated the address of our intranet which is also SSL. There is so autodiscovery going on that is more dangerous than good.

      • Anonymous commented  ·   ·  Flag as inappropriate

        It's horrible but when I try to connect to my SharePoint 2016 on Prem it will not work. I use FBA authentication and still the problem with ssl. When using connection without ssl it works. I have this problem from the first time the app was published and still not solved. :-/

      • Larry commented  ·   ·  Flag as inappropriate

        The answer for us seemed to be rooted in the October Sharepoint Update. I do not know how we moved past the October Update but as of about mid-December, the "Alamofire AFError" no longer shows itself!

      • Anonymous commented  ·   ·  Flag as inappropriate

        I was so happy I found this app to see if I have a better support in my ipad than using the OndDrive app. When I launched the, the day was ruined and I seem not to be the only one. Shame

      • Larry commented  ·   ·  Flag as inappropriate

        Since this started for us, approximately October 10, 2017, there have been at least 2 Sharepoint App updates for IPhone. Each time I update the App, but still the same "Alamofire.AFError error 3" message comes up. I start with updating the App and then move to updating the IOS version. Is there a fix for this anywhere in sight?

      • Anonymous commented  ·   ·  Flag as inappropriate

        I can second Larry's experience. The "Alamofire.AFError error 3" is thrown here as well.

      • Larry commented  ·   ·  Flag as inappropriate

        Is this still an issue that is actively being worked on? Our company's Sharepoint app on IPhones is giving us the "Alamofire.AFError error 3"" error with "Something went Wrong". It has been over 2 weeks. A recent app update to 3.4.0 did not help. The error happens on IOS 10 and 11.03. Does anyone have any suggestions?

      • Andrew commented  ·   ·  Flag as inappropriate

        I saw someone mention it works "fine" in Safari, but I have both 2010 and 2016 extranets, and only the 2010 farm using NTLM and publicly trusted SSL cert will connect in either Safari or the app. The SP 2016 farm running claims/kerberos and publicly trusted SSL will not even authenticate, but does work in the Puffin browser, as well as on Android devices, and Windows of course. It also doesn't work in Safari on mac.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Getting inconsistent experiences with page views. The right hand of the page is cut off. You just can't see it. And you can't get to it.

      • Julian commented  ·   ·  Flag as inappropriate

        Works fine in Safari, errors with "something went wrong" Alamofire.AFError error 3 in the app for following, popular and links. People tab doesn't work.

      • Tim Eggleston commented  ·   ·  Flag as inappropriate

        Works fine in Safari, fails in the SP app. Site is HTTPS using a publicly-trusted SSL certificate, reverse-proxied using a Netscaler.

      • Sajith commented  ·   ·  Flag as inappropriate

        We are getting following error.
        Something went wrong, Technical details: The operation couldnt be completed. (Alamofire.AFError error 3.). Customer use NTLM Authentication.

      • Brent Everett commented  ·   ·  Flag as inappropriate

        I have no problem connecting to our on-prem site with the app, but it says, "There is nothing here yet". Is there something that must be done on the server side so the app can see the content?

      • Mike Murray commented  ·   ·  Flag as inappropriate

        Can someone please confirm: the SharePoint App for iOS does need a publically trusted certificate to work?

      • JoeD commented  ·   ·  Flag as inappropriate

        OnPrem does not work for me, though it does work for others in my company. I am a SharePoint admin, and when we migrated to SP 2013, every site in the farm appears in my "Following" list, so when I use the mobile app, the Sites tab just spins at "Loading..." and never returns. I assume this is because the sheer number of sites that show up under my Following list, which I cannot seem to be able to clear with Powershell scripts.

      • TM commented  ·   ·  Flag as inappropriate

        Still having issues connecting. We are using HTTPS. Works for all other users except for my account. My account is the farm admin. I had my account duplicated in AD and was able to connect using that account.

      • Pheonia commented  ·   ·  Flag as inappropriate

        Would be useful to have an option for ignoring SSL trust errors so we can still use HTTPS with internal CA certificates for developing/testing purposes.

      ← Previous 1

      Feedback and Knowledge Base