SharePoint
Feedback by UserVoice

How can we improve Microsoft SharePoint Apps for iOS?

Custom Lists

Please make accessing and working with custom lists available! Or am I the only one getting an errormessage "something went wrong" each time I try?

86 votes
Vote
Sign in
(thinking…)
Password icon
Signed in as (Sign out)
You have left! (?) (thinking…)
Per Magnus Byström shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

14 comments

Sign in
(thinking…)
Password icon
Signed in as (Sign out)
Submitting...
  • Adrian Lochan commented  ·   ·  Flag as inappropriate

    After my 15 column I get a Something went wrong message with Correlation ID: 620c6a9e-903c-6000-b3f3-a3391863848f
    Error code: -2147024749

  • Janine commented  ·   ·  Flag as inappropriate

    Please make look up fields work on the App. I have a custom list with one lookup field. I can see the list contents, however when trying to search it returns the error "Something went wrong"

    Thanks.

  • Ken commented  ·   ·  Flag as inappropriate

    I have the same issue, if I go to Home in the app and drill down to my list I can use it without issues. Selecting it from Lists causes the Something Went Wrong Error. Is there a fix for this? Clearing the Account Cache did not help. My list has quite a few fields and has one lookup of another list in the same site. Other than that it is not terribly complicated.

  • Teerasit Songtis commented  ·   ·  Flag as inappropriate

    Hi,
    I've just found the solution.
    In iOS App, go to Settings, and then Clear Account Cache. After that open that problematic sharepoint list again. Then, it's ok. ^^

  • mk commented  ·   ·  Flag as inappropriate

    I have a similar problem here!
    And I think Lee's comment points out one of the problems.

    ”Think I found out what the issue was I was able to replicate. If you have a list with 4 items and open using the app I can see the list items. If I then delete a column and try to use the ios sharepoint app again I get the Something Went Wrong Message”

  • Aeleceos commented  ·   ·  Flag as inappropriate

    Do we have any updates regarding this issue which is affecting List sites using iPhone's/iPad's?

  • Hans Taf commented  ·   ·  Flag as inappropriate

    Same problem here:
    I created a list in my teamwebsite and then I created a site column (lookup type) under Site Settings -> Web Designer Galleries -> Site columns -> Create.
    When I add these column in a list located in a subwebsite, the list works in SharePoint Online, but in SharePoint App for iOS I recieve the error "Something went wrong".
    Please fix this issue.

  • Sorapol Tantiyapong commented  ·   ·  Flag as inappropriate

    More Information example you have 1 list and you create more view with filter like create by eq [me] this mean you can see some items in the list base your user create items. Currently SharePoint mobile app cannot display this view type show only message "Something when wrong" from my idea this basic common function may need you help to improve soon. Thank you

  • Teemu commented  ·   ·  Flag as inappropriate

    Custom lists are not listed and therefore not accessible at all.

  • Lee commented  ·   ·  Flag as inappropriate

    Think I found out what the issue was I was able to replicate. If you have a list with 4 items and open using the app I can see the list items. If I then delete a column and try to use the ios sharepoint app again I get the Something Went Wrong Message

  • Anonymous commented  ·   ·  Flag as inappropriate

    Having a similar problem where we are trying to add an item to a custom list. When we tap the plus button we get an error message that says "Something went wrong". We can edit items though.

  • Anonymous commented  ·   ·  Flag as inappropriate

    this issue is occurring with several custom lists that I have created including InfoPath List forms. It doesn't render any content and displays something went wrong message

  • Martin commented  ·   ·  Flag as inappropriate

    When I try working on an element from a custom list, i get the message, that this option will be available soon. I don´t get an error-message.

Feedback and Knowledge Base